¶ ProCurve Commands
enable
configure
hostname @hostname
ip domain-name @domain
interface @interface
name "@description"
ip address @IP @MASK
no shutdown
ip helper-server @IP_DNS
dhcp-server @IP_DHCP_SERVER
dhcp-server @IP_DHCP_SERVER2
ip helper-address @IP_DHCP_SERVER
ip route 0.0.0.0 0.0.0.0 @GATEWAY_IP
timesync ntp
ntp
ntp server @IP_NTP
ntp server @IP_NTP2
ntp authentication
ntp authentication-key @KEY_ID md5 @PASSWORD
crypto key generate ssh rsa bits 2048
ip ssh
ip ssh cipher aes256-ctr aes192-ctr aes128-ctr
ip ssh mac hmac-sha2-512 hmac-sha2-256 hmac-sha1
ip ssh filetransfer
aaa authentication local-user @username password @password
aaa authentication local-user @username group administrators
vlan @VLAN_ID
name "@VLAN_NAME"
untagged @PORT_LIST
ip address @IP @MASK
exit
interface @interface
untagged vlan @VLAN_ID
interface @interface
tagged vlan @VLAN_LIST
untagged vlan @NATIVE_VLAN_ID
no vlan @VLAN_ID
show vlans
show vlan @VLAN_ID
ip routing
ip route @DESTINATION_NETWORK @MASK @NEXT_HOP
router rip
enable
network @NETWORK_ADDRESS
no auto-summary
router ospf
enable
area 0
network @NETWORK_ADDRESS @WILDCARD_MASK area 0
¶ Create Standard ACL
ip access-list standard @ACL_NAME
permit @SOURCE_IP @WILDCARD_MASK
deny @SOURCE_IP @WILDCARD_MASK
exit
ip access-list extended @ACL_NAME
permit tcp @SOURCE_IP @SOURCE_WILDCARD @DESTINATION_IP @DESTINATION_WILDCARD eq @PORT
deny ip any any
exit
interface @interface
ip access-group @ACL_NAME in
ip access-group @ACL_NAME out
show access-list
show access-list @ACL_NAME
show access-list config
spanning-tree
spanning-tree mode mstp
spanning-tree config-name @CONFIG_NAME
spanning-tree config-revision @REVISION_NUMBER
spanning-tree mode rapid-pvst
spanning-tree priority @PRIORITY
spanning-tree vlan @VLAN_ID priority @PRIORITY
interface @interface
spanning-tree admin-edge-port
spanning-tree bpdu-protection
spanning-tree root-guard
show spanning-tree
show spanning-tree config
show spanning-tree instance @INSTANCE_ID
trunk @PORT_LIST trk1 lacp
trunk @PORT_LIST trk1 trunk
interface @PORT_RANGE
lacp active
exit
trunk @PORT_LIST trk1 lacp
show trunks
show lacp
password manager user-name @USERNAME
password operator user-name @USERNAME
password all min-length @LENGTH
aaa authentication local-user @USERNAME group administrators password @PASSWORD
aaa authentication console login local
aaa authentication console enable local
aaa authentication ssh login local
aaa authentication ssh enable local
password all encrypt
interface @interface
ip source-binding ip @IP mac @MAC vlan @VLAN_ID
dhcp-snooping
dhcp-snooping vlan @VLAN_ID
interface @interface
dhcp-snooping trust
arp-protect
arp-protect vlan @VLAN_ID
interface @interface
arp-protect trust
radius-server host @RADIUS_IP key @SECRET
aaa authentication login radius local
aaa authentication enable radius local
radius-server host @RADIUS_IP acct-port 1813 key @SECRET
aaa accounting commands radius
aaa accounting network start-stop radius
show radius
show authentication
aaa port-access authenticator @PORT_LIST
aaa port-access authenticator @PORT_LIST auth-vid @VLAN_ID
aaa port-access authenticator @PORT_LIST unauth-vid @VLAN_ID
aaa port-access authenticator @PORT_LIST client-limit @NUMBER
aaa authentication port-access eap-radius
aaa port-access authenticator @PORT_LIST
show port-access authenticator
show port-access authenticator @PORT_LIST
show port-access authenticator config
qos type-of-service diff-services
qos classifier @NAME ip precedence @PRECEDENCE_VALUES
qos queue-config @QUEUE_NUMBER priority @PRIORITY
interface @interface
qos priority @PRIORITY
qos dscp @DSCP_VALUE
qos trust dscp
show qos
show qos interface @interface
mirror @PORT_NUMBER port @SOURCE_PORT
mirror remote ip @SOURCE_IP @DESTINATION_IP @SOURCE_UDP_PORT @DESTINATION_UDP_PORT
show monitor
ip igmp
vlan @VLAN_ID ip igmp
ip multicast-routing
router pim
enable
vlan @VLAN_ID ip pim-sparse
vlan @VLAN_ID ip pim-dense
show ip igmp config
show ip pim
ipv6 enable
ipv6 routing
vlan @VLAN_ID
ipv6 address @IPv6_ADDRESS/@PREFIX_LENGTH
exit
ipv6 route @IPv6_PREFIX/@PREFIX_LENGTH @NEXT_HOP
show ipv6
show ipv6 route
snmp-server community @COMMUNITY_STRING operator
snmp-server community @COMMUNITY_STRING manager
snmp-server host @IP_ADDRESS community @COMMUNITY_STRING
snmp-server user @USERNAME auth md5 @AUTH_PASSWORD priv des @PRIV_PASSWORD
snmp-server group @GROUP_NAME user @USERNAME sec-model ver3
show snmp-server
show snmp-server community
stacking enable
stacking member @MEMBER_ID type @SWITCH_TYPE
stacking member @MEMBER_ID priority @PRIORITY
show stacking
copy tftp flash @TFTP_SERVER @FILENAME primary
copy tftp flash @TFTP_SERVER @FILENAME secondary
boot system flash primary
boot system flash secondary
show flash
show version
write memory
copy startup-config tftp @TFTP_SERVER @FILENAME
copy running-config tftp @TFTP_SERVER @FILENAME
copy tftp startup-config @TFTP_SERVER @FILENAME
copy tftp running-config @TFTP_SERVER @FILENAME
erase startup-config
reload
show config
show running-config
show tech
¶ Debug Commands
debug spanning-tree
debug lacp
debug arp
debug dhcp
debug ip routing
logging @SYSLOG_SERVER
logging facility @FACILITY
logging severity @LEVEL
show log
show debug